## Installation & Operation Manual

### Contents

<table>
<thead>
<tr>
<th>Design Statements, Warnings</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smarty Models, Standard Features</td>
<td>2</td>
</tr>
<tr>
<td>Carrier Ratings and Features</td>
<td>2, 3</td>
</tr>
<tr>
<td>Smarty Software and XIO Options</td>
<td>3</td>
</tr>
<tr>
<td>Smarty Installation and Front Panel</td>
<td>4</td>
</tr>
<tr>
<td>Carrier Terminals, Dimensions, and Data</td>
<td>4, 5, 6</td>
</tr>
<tr>
<td>Smarty Terminals, Ratings, and IO Functions</td>
<td>7</td>
</tr>
<tr>
<td>Get savvy®, USB Plug and Play, Ethernet Networking</td>
<td>8, 9</td>
</tr>
<tr>
<td>Get started with savvy® engineering &amp; design software</td>
<td>9, 10</td>
</tr>
<tr>
<td>Upgrade savvy® and smarty®</td>
<td>10</td>
</tr>
<tr>
<td>SavvyPanel® Touch Screen Operator Station</td>
<td>10, 11</td>
</tr>
<tr>
<td>Smarty Precision Motion Functions and Connections</td>
<td>12</td>
</tr>
<tr>
<td>Smarty Comms Interfaces, Modbus, EIP</td>
<td>12</td>
</tr>
<tr>
<td>Free drive.web® Online Training Seminars</td>
<td>12</td>
</tr>
</tbody>
</table>

### Certification Statements

This process control equipment to be supplied by Class2, LPS, limited power supply.

### Design Statements

**EMC Standard,** EN 61326-1: 2006, Electrical Equipment for Measurement, Control and Laboratory Use.

**Emissions Class A,** Commercial Equipment.

**Immunity Table 2,** Industrial Equipment.

**LVD Standards,** EN 61010-1: 2010, Safety Requirements for Electrical Equipment for Measurement, Control and Laboratory Use and;

**EN 61010-2-030:** Particular Requirements for Testing and Measuring Circuits.

**Smarty** is an industrial controller designed for permanent installation by qualified professionals. If it is used in a manner not specified herein, the protection provided may be impaired.

**Smarty** and its packaging contain recyclable materials.

This device is designed to comply with Part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) This device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause undesired operation.

**Warning!** It is essential that you read and understand this entire manual and the entire contents of the Savvy software Help menu before proceeding with your installation and configuration. See page 6 for savvy® installation instructions. For more information and to download manuals and software, go to [www.driveweb.com](http://www.driveweb.com) or contact us. See page 12.

**Warning!** Your use of savvy® software and drive.web® devices may cause motors and machinery to power up with high Voltages or start or operate in an unexpected, dangerous or lethal way. It is essential that you are completely familiar with all of the equipment and the system design before attempting to program or edit a program or connect to any live device. It is also essential that a risk assessment is conducted to identify hazards. Risks must be reduced to tolerable levels.

**Warning!** You are entirely responsible for the configuration or use of any drive.web® product. By configuring or using these products you agree to indemnify and hold harmless Bardac Corporation, its employees, directors, officers, distributors, and resellers against the consequences of your configuration or use of the products.

**Warning!** Information in this manual is subject to change without notice. You are responsible for verifying the proper operation of your Smarty. Special care must be taken after loading new firmware or installing new options.

SMARTY, SAVVV, SAVVYPANEL, SPEEDY, BARDAC, and DRIVE.WEB® are trade marks of Bardac Corporation, registered in the U.S. and other countries.
**Warning!** Avoid permanent damage to your **smarty**, never exceed any **min** or **max** values. Do not connect any **smarty** terminal to mains circuits. See page 5 for IO ratings.

lwIP is incorporated into **smarty** firmware. lwIP Copyright (c) 2001-2004 Swedish Institute of Computer Science. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

This SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

**Product Identification - ** **smarty**

The **smarty dw24X** Series Universal Automation Controllers (UAC) consist of a range of “Cassette” computer modules that plug into a range of “Carrier” terminal modules that provide optional user interface ports and field wiring input and output terminals.

- **smarty1 - dw241** Cassette + **C1 Carrier**, 39 terminals, 105 mm long.
- **smarty2 - dw24x** Cassette + **C2 Carrier**, 39 terminals, ports, 105 mm long.
- **smarty3 - dw24x** Cassette + **C3 Carrier**, 61 terminals, ports, 140 mm long.
- **smarty4 - dw24x** Cassette + **C4 Carrier**, 103 terminals, ports, 210 mm long.

Find **smarty** cassette model and firmware version. Use **savvy, Get Detailed Info** from **smarty** contextual menu. See page 6.

**Warning!** Avoid permanent damage to **smarty**. Disconnect all power sources prior to inserting or removing the cassette.

**Product Identification - Part Numbers**

Model number **dw24x** is appended with a two or six character extension.

Example; **dw240-DM-C4CD**

<table>
<thead>
<tr>
<th>Cassette Model</th>
<th>Mounting Type</th>
<th>Terminal Type</th>
<th>Carrier Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>D=DINrail, F=Foot, A=Spacer</td>
<td>C=Clamp, S=Screw, P=Plug-in</td>
<td></td>
</tr>
<tr>
<td><strong>smarty</strong> Cassette Models</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>dw240</strong> UAC for Carriers <strong>C2, C3, and C4.</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>dw241</strong> Basic automation controller for carrier <strong>C1</strong> only.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>dw244</strong> UAC for <strong>P2</strong> industrial vector drive with Carriers <strong>C2, C3, and C4.</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>dw248</strong> UAC for <strong>E3</strong> open-loop vector drive with Carriers <strong>C2, C3, and C4.</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>dw249</strong> UAC for <strong>CANopen</strong> server devices with Carriers <strong>C2, C3, and C4.</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Standard Builds A, B, C, and D - Software Options**

- **A=04** and **26**, **B** adds **05** and **25**, **C** adds **06** and **39**, **D** adds **10** and **29**.
- **04 ModbusTCP/IP** - Slave/server. See page 12.
- **05 Process Control** - Recommended for most applications.
- **06 Winder Control** - Diameter Calc., Taper Tension, Torque Comp.
- **10 Math** - With advanced math functions.
- **26 savvyPanel** - Operator station interface. See pages 8, 9.
- **29 Solar** - Calculates sun position azimuth and zenith.
- **39 Precision Motion** - With event, length, position, shaft-lock, indexing, motion control, cam profile, and more. Page 12.
**smarty C1** Carrier 1 Ratings and Features *(dw241 only)*
- **drive.web** distributed process control.
- 10BaseT / 100baseTX Ethernet. See page 4.
- USB peripheral, micro B.
- Eight bipolar analog inputs: -11VDC to +11VDC, 100kΩ, 1kHz.
- Eight unipolar analog outputs: ~0.2VDC to 10.5VDC, 10mA.
  Can be used as reference Voltage.
- Eight digital inputs: 50VDC max, 8VDC threshold, 3V hysteresis.
  1kHz. Can be used as event inputs. Page 5.
- Eight digital outputs: 24VDC source, up to 350mA, shared. Overcurrent protection and software indication. Maximum Voltage is 25.2VDC.
- Extra terminals for cabinet-side power; +24VDC, 0V.

**smarty C2** Carrier 2 Ratings and Features adds to C1
- Battery backup for realtime clock: standard CR2032.
- Bipolar analog outputs replace unipolar: -10.5VDC to +10.5VDC.
- CANopen and ModbusRTU serial ports jack.
- XIO port jack for extended IO modules. Up to ten modules.

**smarty C3** Carrier 3 Ratings and Features adds to C2
- Four *FT* frequency/timing channels, multi-function; Frequency/event/digital input, 5VDC max, 100kHz. Frequency/stepper/digital output, 5V sinking, 350mA shared, 500kHz.
- Differential, incremental, quadrature encoder input. 5.5VDC max, -0.5VDC min., 0.3VDC minimum differential Voltage. Up to 1MHz.
- ModbusRTU serial port is brought out to terminals instead of the jack in C2.

**smarty C4** Carrier 4 Ratings and Features adds to C3
- Two 4-20mA current inputs. Also 0-20mA, 20-4mA, and 20-0mA. 100Ω input impedance. Maximum input is 25mA, 2.5VDC.
- Six frequency/event/digital inputs, 30Vmax, 100kHz. Replaces *FT* on C3.
- Seven frequency/stepper/digital outputs, sinking with connectable *TPW* pull-up rail, 350mA shared, 30VDC max., 500kHz max. Replaces *FT* on C3.
- Two differential, incremental, quadrature encoder inputs with markers, ABZ, Encoder 1, 2; A, B, reconnect terminals.

**smarty XIO Digital IO Module Options** *(Available Soon)*
- Up to 10 modules may be added.
- DINrail modules must be mounted directly to the right of the *smarty* carrier or the next XIO module in line.
- Easy 4P4C plug-in, 60mm cable is included.
- Module dimensions are the same as C1, page 4.
- Separate manuals are supplied with each module.
- XIO-8H-6H - Eight 120VAC/240VAC in and six 120VAC/240VAC, 0.2A out.
- XIO-16H-0 - Sixteen 120VAC/240VAC inputs.
- XIO-0-8HC - Eight 120VAC/240VAC, 2A outputs.
- XIO-8-8 - Eight 24VAC/DC in and eight 24VAC/DC, 20mA (50Ω) out.
- XIO-16-0 - Sixteen 24VAC/DC inputs.
**smarty Installation**

*smarty* is designed for permanent installation by qualified professionals. Install *smarty* in metal enclosure with no RF noise source.

**DIN rail mounting** - Use 35x7.5mm rail per IEC 60715 or EN50022.

**Environment** - UL/IEC Pollution Degree 2.
- Operating temperature, 0°C min., 50°C max.
- Storage temperature, -20°C to 60°C.
- Altitude 3000m max.
- Humidity 95% max. non-condensing.

**Clearances must** be provided around cassette to promote airflow, 25mm (1”).

**smarty Cassette Front Panel**

**USB port** - Peripheral-type micro-B jack. Can be used for backup power to maintain the realtime clock.

**Ethernet port** - MDI 8P8C, “RJ45” jack, 100baseTX and 10BaseT, Full Duplex, Auto Negotiation, Auto-MDIX, IEEE 802.3ab.

**Indicator LEDs** in front panel:

- **Status** - Blue LED. Status heartbeat pulses twice a second.
- **Fault** - Red LED. Check power supply, connect with *savvy*, or contact us at drive.web for more information.
- **Ethernet link/activity** - Orange LED indicates Ethernet connection and blinks for activity.

**100 100BaseTX** - Green LED when 100BaseTX connection is made.

**Carriers C1 and C2**

**Terminals and Dimensions**

<table>
<thead>
<tr>
<th>Width Overall</th>
<th>Height Overall</th>
</tr>
</thead>
<tbody>
<tr>
<td>104.5mm (4.11”)</td>
<td>87mm (3.43”)</td>
</tr>
</tbody>
</table>
**Drive.webmavtation**

**Realtime Clock Battery, CR2032.**
(Realtime clock will be maintained for approximately 24hrs with no backup battery.)

DI = Digital Input
DO = Digital Output
AO = Analog Output
AI = Analog Input
1A = Encoder 1 Channel A
1B = Encoder 1 Channel B
5V = 5VDC Power Output
FT = Frequency/Timing IO
A, B = ModbusRTU

**Dimensions**

- **Width Overall,** 140mm (5.51”)
- **Height Overall,** 87mm (3.43”)
- **Overall Height:** Back Panel to Front Panel 75mm (2.95”)
**Carrier C4 Terminals and Dimensions**

- **8P8C CANopen Serial Port**
- **Realtime Clock Battery, CR2032.** (Realtime clock will be maintained for approximately 24hrs with no backup battery.)

**DI = Digital Input**  
**DO = Digital Output**  
**AO = Analog Output**  
**AI = Analog Input**  
**CI = Current Input**  
**1A = Encoder 1 Channel A**  
**1B = Encoder 1 Channel B**  
**1Z = Encoder 1 Marker**  
**5V = 5VDC Power Output**  
**FI = Frequency Input**  
**TPW = Power Input for TO**  
**TO = Timing Output**  
**A, B = ModbusRTU**

**Width Overall, 210mm (8.27")**  
**Height Overall, 87mm (3.43")**

**4P4C XIO Port**
Terminals and Ratings

**Terminal wiring** - Strip 7mm(0.28") or use ferrules. Use 0.08mm² (AWG28) minimum. One bare wire, 2.5mm² (AWG14) max. Two wires, 0.8mm²(AWG18) max. One wire with ferrule, 1.5mm²(AWG16) maximum. Use shielded cable for runs over 30 meters.

Fast transient over-Voltage 1kV per EN 61000-4-4.

**24VDC and 0V Terminals are internally connected.**

Regulated 24VDC ±5%, 100mA plus loads.

Do not connect to a distributed DC power network.

**External 1A fast-acting fuse or current-limiting is required!**

Supply from Class 2, LPS, limited power supply only.

5V Terminals are power supply outputs for use with encoders, sensors, and the **TPW** terminal on **C4**.

Maximum total current output is 500mA.

**TPW** terminal on **C4** is the power input for **TO** timing outputs.

Maximum input Voltage is 30VDC max.

**FT and TO** 350mA total, shared maximum current. Sinking outputs without internal over-current protection. The installing engineer must assess the risk of overload and provide external protection to avoid damage to the unit, depending on the installation.

**Signal Wiring Notes**

Use twisted-pair wiring for encoder and serial differential signals.

- Outside metal enclosure, use shielded cable with individually shielded twisted-pairs such as **Belden 8163**. Ground shield at one end with a 360° ground clamp where cable enters “quiet” metal enclosure.

- Separate wiring from AC power cables or RF noise sources.

I/O Functions

**Digital and Event Inputs** - Maximum event frequency is 1/(2*FBE cycle s) Hz. For 5ms FBE cycle, the max event frequency is 1/10ms = 100Hz.

**DI** threshold = 8VDC±3VDC.

**FI** and **FT** thresholds with selectable, internal pull-up or pull-down.

- Pull-Down = 2VDC (1.2Vmin, 2.9Vmax)
- Pull-Up = 1.2VDC (0.5Vmin, 1.9Vmax)

**Encoder and Counter Inputs** - Provide frequency data with adjustable moving average filter and count outputs for use with precision motion and position function blocks.

**Frequency Inputs** - Useful for lower frequencies ~<10kHz. Duty cycle is also measured. Updates every FBE cycle or two-edge cycle.

**Digital Outputs** - source 24VDC.

**Timing Outputs - FT** terminals sink with 10kΩ pull-up to 5VDC.

**TO** terminals sink with 10kΩ pull-up to **TPW**.

**TPW** can be connected to 5V, 24V, or up to 30VDC max.
Set up your computer - Get savvy
With free drive.web savvy software, easily program and monitor yoursmarty, perform data trending, and create distributed control systems.

- Go to www.driveweb.com and click on Get savvy, or contact us to get the latest version of savvy.

smarty USB - Plug and Play
Plug-and-play access to smarty and its local Ethernet network.

smarty Ethernet Networking & Programming
Assigning an invalid or duplicate IP address will cause serious network malfunctions!

- Find useful networking information. Under the Help menu click on Getting Started with savvy section.
- smartrys are shipped with an IP address, 10.189.x.x, derived from the serial number. The six-octet serial number always starts with 0-4-bb-x. The last two octets are used to assign the as-shipped IP address; Example, if the serial number is 0-4-bb-00-1a-2b, 1a is converted from hexadecimal to decimal, 26. 2b, similarly, is 43, decimal. The as-shipped address is 10.189.26.43.
- Use Category 5e cable or better, with 8P8C/RJ-45 connectors for each drive.web device and the host computer.
- For systems with more than one drive.web device, use an Ethernet switch for all drive.web devices and computer.

Get started with savvy

- We strongly recommend attending our free online training seminars. See page 12.
- We strongly recommend you read the User Manual and Getting Started Guides under the Help menu.
- Use Create Phantom in the Directory menu to explore drive.web products and options, design, and configure offline. Export Data to save your work. Import Data into phantoms to work offline.

savvy Window Title Bar indicates the current view.

Status Bar, above the viewing area, provides Navigation Arrows and object and location data.

- savvy views are hierarchical with the Device Directory View at top. Use the Navigation Arrows to go up, back, or forward. Window menus change as you navigate.

Hover cursor over active object, device, function block, connection, or parameter icon to view object information in the Status Bar and reveal a Hover Button.

Click a Hover Button or right-click an active object to access a Contextual Menu. See below.

savvy functions are limited by password-protected capability level. See File > Capability...
Device Directory Window

**Warning!** Changing a device IP address **WILL** disrupt its network connections! If a *smarty* is communicating with other devices, be prepared for system disruption. In the File menu choose **Utility > Remap Export File** to remap a `dw-system` file with different IP address(es).

- Select **File > Administer > Set IP Addresses for System.**
- *smarty* serial number is also its `MAC Address`.
- Enter a valid IP address and click OK.

An icon appears with IP address beneath. Drive-dedicated models depict the actual frame size of the drive.

If the icon at right appears, a network connection problem exists. Check connections, LEDs, and that the *smarty* IP address is within the computer’s Ethernet subnet mask.

**Warning!** Importing data into your *smarty* will result in immediate execution of that configuration. **Dangerous Voltages and rotating machinery may result!** Use a phantom to preview a configuration.

- **Directory > Import / Export Data.** All device configurations and connections in the directory in one `dw-system` file.

*smarty* Icon Contextual Menu

- **Change Name** - Name your *smarty* for easy identification.
- **Import / Export Device Data...** - Load / save configuration data to / from this *smarty* only.
- **Unlock, Lock, Set Password** - Choose Restrict Modification to allow viewing the configuration, or Restrict All Access.

Click the *smarty* icon to view the device configuration.

Function Block Engine Window - FBE Menu

(Standard **savvy**, no **SFD**)

- Add function blocks in the order to be processed. Processing order is left to right, top to bottom.

Click function blocks to view parameters and details.

Connect between parameters and other `drive.web` devices.

**Warning!** Making a connection results in immediate execution of that connection. **Dangerous Voltages and rotating machinery may result!**

- Under the File menu, choose **New Viewer...** and then, **File > Open Device Directory.**
- With two viewer windows, click a parameter, drag and drop onto a parameter in the other viewer.

Parameter Contextual Menu - Data is formatted, limited, and scaled depending on the parameter. Use **Get Info** or **Re-Scale...** to verify or change.

Click parameters for the Setter Box - Increment, decrement, default, last state, or keyboard entry.

Click blue connection block or arrow to jump to other end.
Upgrade **savvy** and **smarty**

Upgrade **savvy** with **SFD Signal Flow Diagram**.
Upgrade **smarty** with software options.

Process credit cards or **Vouchers** online or **Coupons** offline.

- To upgrade **savvy**, go to the **Commerce** menu, select **Upgrade savvy**, check desired options, click OK.
- To upgrade **smarty**, choose **Upgrade Device…** in its contextual menu, check desired options, click OK.
- To process **Vouchers**, choose **Pay > Online Via Vouchers** in the **Shopping Cart**. Enter **Voucher** codes on separate lines.
- To process **Coupons**, go to the **Commerce** menu and choose **Coupon Manager**. Enter codes in the top box and click the **Add** button and the coupon is recognized. Click **Apply**.

**savvy-SFD Signal Flow Diagram Upgrade**

- With **savvy-SFD**, build systems graphically. The live drawings are stored in your **smarty**.
- Set drawing borders and annotate multi-page drawings.
- A filterable list of function blocks and connections is at the left of the **Signal Flow Diagram** showing **program execution order** from top down. Change execution order by dragging function blocks up or down the list. In this picture, **ENC1 Speed** function block is moved so that it is processed after **ENC Phase Lock**.

**savvyPanel Operator Station**

Computers, Apple® mobile digital devices; iPad®, iPhone®, and iPod Touch® are operator touch stations with **savvyPanel**. Requires Windows(XP, Vista, 7), Mac OS X, Linux-based Ubuntu, or iOS®.

- Configurations are stored in the **drive.web** devices.
- **savvy-SFD** upgrade is required to edit or build **savvyPanel** systems.
- **dwOption-26 savvyPanel**, must be installed in **drive.web** devices to enable the full suite of tiles. A limited set is available without the option.

Get **savvyPanel** free from the Apple App Store℠

- When your iPad or iPhone is connected to the internet via WiFi, demo mode connects to a live drive system in our plant in Maryland, USA.
- Explore the demo with **savvy**. Select **File > Demo Mode > Discover Internet Demo Devices**.
**savvyPanel** Pages

**Systems Page** where multiple **savvyPanel** systems are present.
- A **savvyPanel** system may contain tiles from many **drive.web** devices.
- A **drive.web** device contributes to only one **savvyPanel** system.
- Touch the systems button, ﬁn or ﬁsh, in the window bar to access the systems page from home page. Lock this button with home password.

**Home Page** is the first operator page in a **savvyPanel** system.
- Access home page from any operator page with the home button, ﬂag. Lock with the home password.

**Operator Pages** show graphic, page-link, and parameter tiles.
- Pages can be renamed. Page name appears in window title bar.

**savvyPanel Tiles**

**Parameter Tiles** - Touch a settable parameter to set. Setter includes slider, keypad, 1x and 10x increment and decrement, return-to-default, and revert.

**Graphic Tiles** - Create diagrams with process elements.

**Page-Link Tiles** - A graphic tile that is also a page-link. Touch to change the view to that page.

**Device Tiles** - Link to device’s signal flow diagram in Java-based **savvyPanel**. Appears as graphic tile in iOS.

**Function blocks enable **savvyPanel** actions**

**Alarm Annunciator** - Provides a system-wide alarm annunciation when active. Touch to view page 255.

**Presence Monitor** - Indicates the presence of a tagged **savvyPanel** application viewing a particular page.

**Latch** and **SR Latch** - For lighted start-stop pushbuttons.

**Setpoint & Monitor** - Adjust meter and setter range. Dual blocks enable dual-display meters.

**Enumerated Parameter** - In **Utility** group. Only custom enumerations appear in the setter and multi-position switch.

**savvyPanel Launch, Setup, and Important Notes**
- See the **savvy** user manual for detailed instructions.
- Launch **savvyPanel** via command line or batch file.
- Limit operators to **savvyPanel** only. Specify start system and page.
- Discover devices automatically, specifically by discovery file, or filtered by group and/or **savvyPanel** name.
- Operator’s note: If communication with a **drive.web** device is interrupted, affected tiles indicate a yellow bar with a warning symbol. The tile is not updated.

**Important Design Note** - An over-range enumeration is required if an out-of-range value could cause a hazard.
**smarty Precision Motion Functions, Connections**

Special parameter and connection types from I/O function blocks.

- **Floating Point** - IEEE-754 Binary32 values for frequency, speed, position, and other wide value ranges. Floating point math function blocks are available for additional processing.

- **Event** - Events are associated with exact count values. Maximum event frequency is \(1/(\text{FBE Timebase seconds})\) Hz. Only the first event is processed per FBE cycle.

- **Count** - Position applications including shaft-lock, motion control, and registration. 64-bit internal values with precision timing data.

**smarty Comms Interfaces-Modbus & EIP/PCCC**

**Warning!** Use of **smarty** comms interfaces, ModbusTCP, ModbusRTU, and EIP/PCCC, may cause motors and machinery to energize with high Voltages, or start, or operate in an unexpected, dangerous, or lethal way.

For Modbus specs go to [http://modbus.org/specs.php](http://modbus.org/specs.php)

**smarty Comms Server dwOption-04 and -25**

- **Note!** You cannot write or force parameters that are read-only or have incoming **drive.web** connections.
- Click the **Comms Server** icon in the **FBE** or **SFD** view.

- **dwOption-04 ModbusTCP/IP slave/server**
  - Supported Modbus Function Codes; 1 thru 6, 15, and 16.
  - Supports up to five simultaneous clients/masters.

- **dwOption-25 EIP/PCCC Server**
  - Supports PLC5 Typed-Write and Typed-Read commands.
  - See Appendix B of the **savvy** User Manual for information and **drive.web** parameter IDs mapping to PLC5.
  - Supports up to two simultaneous clients.

**ModbusRTU Type** (not available in C1)

- **M**=Master-Client, **S**=Slave-Server, **X**=None-e.g. **dw241**.
- Modbus Function Codes **FC 01** through **06** and **16** are supported. Also special Yaskawa Holding Register.
- Each server’s Modbus address must be unique on the network!
- All devices on the network must have the same baud rate, up to **500.0kbps**, and the same character framing.

**drive.web Training Courses**

Free online interactive training seminars take about one hour. Specialized online and factory training sessions are also available.

To register email **training@driveweb.com** or call.