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 Warning!
It is  essential that you read and understand this  entire manual, the PL Series  Product Manual, 
HG501441, and the entire contents of the savvy software “Help” menu before proceeding with your 
installation and product configuration. For more information and copies  of product manuals and 
software, go to www.driveweb.com.
 Warning!
Your use of savvy software, drive.web devices  and PL Series  drives  may cause motors and machinery 
to power up with high voltages  or start or operate in an unexpected, dangerous  or lethal way. It is 
essential that you are completely familiar with savvy and all of the equipment and the system design 
you are working with before attempting to program or edit a program or connect to any live device.
 Warning!
You are entirely responsible for the configuration or use of any drive.web product. By configuring or 
using these products you agree to indemnify and hold harmless  Bardac Corporation, its’ employees, 
directors, officers, distributors  and resellers  against the consequences  of your configuration or use of the 
products.

speedy sp  Features
Add interface, intelligence, internet and system connectivity to PL-Series Digital DC drives:

Bardac Corporation, PL series DC drives

Eurotherm, ERCPL series DC drives

Sprint Electric Ltd., PL series DC drives.

drive.web Distributed Process Control over Ethernet

ModbusTCP/IP over Ethernet with option 04.

ModbusRTU for Serial Networks. Option 02 Slave/Server.   
Option 12 Master/Client.

Easy upgrades with savvy software. See page 6.

System libraries; Basic and Optional; Process, Winder and Math.

Function Blocks; Extensive PL-Series  DC Drive parameter control and 
monitoring, Math, logic, PID, comparator, filter, latch, timer, counter, 
ramps, winder diameter, taper tension, torque compensator, more.
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Your speedy sp
Run Mode Ramp

0%

Stopped

41)Crawl Speed

10.00 %

27)Forward Minimum Speed

0.83 %

26)Ramp Input

0.00 %

28)Reverse Minimum Speed

0.00 %

37)Jog Speed 1

5.00 %

38)Jog Speed 2

-5.00 %

39)Slack Speed 1

5.00 %

40)Slack Speed 2

-5.00 %

42)Jog Mode Select

Disabled

C17d)RMR System Reset Pulse Input 29)Ramp Auto Preset

Enabled

30)Ramp External Preset

Disabled

31)Ramp Preset Value

0.00 %

C11s)Run Mode Ramp Demand Output

996)Run Mode Ramps GOTO

65)Ramped Speed Reference 4

21)Ramp Output Monitor

0.83 %

35)Ramping Flag

Low

34)Ramping Threshold

0.50 %

33)Ramp Hold

Disabled

22)Forward Up Time

3.0 secs

23)Forward Down Time

3.0 secs

24)Reverse Up Time

3.0 secs

25)Reverse Down Time

3.0 secs

32)Ramp S-Profile %

2.50 %

43)Jog/Slack Ramp

1.0 secs

56)Stop Ramp Time

6.0 secs

168)Internal Running Mode Monitor

STOP

689)At Jog Flag

Low

714)In Slack Flag

Low

166)Drive Start Flag

Low

Your speedy sp
Current Limits

150%

89)Upper Current Clamp

100.00 %

C2d)Current Limits Iarm Demand Input

91)Extra Current Reference

0.00 %

90)Lower Current Clamp

0.00 %

3)Current Limit (%)

150.00 %

82)Overload % Target

105.00 %

87)Current Limit At Low Current

100.00 %

84)Current Profile Enable

Disabled

81)Current Clamp Scaler

150.00 %

83)Overload Ramp Time

20.0 secs

86)Speed Breakpoint At Low Current

100.00 %

85)Speed Breakpoint At High Current

75.00 %

88)Dual Current Clamps Enable

Enabled

C3s)Current Limits Iarm Demand Output

140)Overload Limit Monitor

150.00 %

136)Upper Current Limit Monitor

150.00 %

137)Lower Current Limit Monitor

0.00 %

138)Actual Upper Limit Monitor

150.00 %

139)Actual Lower Limit Monitor

0.00 %

141)At Current Limit Flag

Low



speedy-sp Options
Software Options 04, 05, 06, and 10 may be added using savvy. See Upgrading, page 6.

See savvy User Manual, Appendix A for complete listing of  available function blocks.

02* ModbusRTU slave. 250V isolated EIA485(RS485), up to 19.2 kbps

04 ModbusTCP/IP.  Ethernet, 10baseT enabled Modbus slave/server. See page 6.

05 Process Control. Function Block Library 1 - Math, Logic, PID, Switches, 
Comparators, User data log, Profiler, Presets, Latch, Filters, Counters, Timers, more. 

06 Winder Control Function Block Library 2 - Diameter Calculator, Taper Tension, 
Torque Compensator.

10 Advanced Math Function Block Library 3 - Trig, Polynomials, Log, Exponent, more. 

12* ModbusRTU Master. 250V isolated EIA485/RS485 serial, up to 115kbps
*ModbusRTU Options 02 and 12 are mutually exclusive. It is  essential that you read 

and understand the entire drive.web Modbus  Installation and Operation Manual, 
HG502421, included with these options before installing them.

speedy sp Winder Specials 
Include options  05 and 06, pre-installed generic winder  system 
configuration and a wiring diagram drawing for fast commissioning of a 
wide range of  winder applications.

1101 speedy sp winder 1  Open Loop Constant Tension Center Winder. 

1102 speedy sp winder 2 Closed Loop Dancer Control Center Winder. 

1103 speedy sp winder 3 Closed Loop Loadcell Control Center Winder.

speedy sp Installation
Dimensions and Weight: 7.8”w, 4.0”h, 1.5”d (198, 101, 38mm)  0.5 lb (0.2 Kg)

Power Requirements: 5VDC, 50mA supplied from the PL-series drive. 

Storage and Operation Environment: Temperature range; 0 to 50˚C. 
Humidity less than 95% non-condensing.

Ethernet Port Standard “RJ45” 8P8C, 10BaseT, LEDs; green, link and yellow, activity.

Warning!
Components on your speedy sp and PL-series printed circuit boards 
are ESD Static Sensitive! 

Do NOT proceed with installation, nor remove your speedy sp from 
its ESD-safe packaging without grounding yourself and your work 
area with static control equipment.

Warning!
Risk of  electric shock resulting in injury or death! 

Your PL-series drive is powered from more than one source of high 
voltage electricity. Remove and isolate all sources of electric power 
before proceeding.  

Only qualified personnel should proceed with installation!
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OPEN LOOP WINDER

CIRCUIT DIAGRAM
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speedy sp Installation continued...

1.Ensure all sources of  electricity are removed and safely isolated. 
2.Loosen the thumb screws and remove the upper and lower terminal covers.
3.Locate and remove the four Philips head screws that hold the drive cover and 

display assembly in place.  You will need a long #2 Philips head screwdriver 
to remove these.

4.Gently lift the cover and display assembly and rotate it upwards and away from 
the drive. Support the assembly above the drive so that you do not 
strain the two ribbon cables.

5.Remove the two nylon screws that hold the PL-series control circuit board in 
place at its’ bottom corners.  You will be replacing these two nylon screws 
with the longer nylon screws and spacers provided with your speedy sp. 

6.Ensure that you are grounded with ESD control equipment. Remove your 
speedy sp from its’ static-safe bag and carefully locate it’s parallel interface 
plug over the corresponding socket on the PL-series control board.  Snap-
clips should align with the holes in the top corners of  your speedy sp.  

7.Gently push down, inserting the plug into the socket and allowing the clips to en-
gage the top edge of  the speedy sp circuit board. Use two hands and apply 
pressure above the socket and at the snap clips to avoid flexing the circuit 
board.

8.Now locate the provided nylon spacers between the PL-series control board and 
the speedy sp board at the bottom corners.  Insert and tighten the two pro-
vided longer nylon screws.

9.Replace the PL series cover and display assembly and reinstall the four mount-
ing screws.

10.Reconnect the power sources to your PL-series drive.
11.Replace the PL terminal covers and tighten the thumb screws. 
12.The speedy sp installation procedure is complete.

speedy sp Ethernet Networking & Programming
Before proceeding, it is  important to have a basic understanding of Ethernet TCP/IP 
networks. Assigning an invalid or duplicate IP address  will cause serious  network 
malfunctions! speedy sps  are all shipped with the same IP address, 10.189.189.189. 
Consult your company’s IT department for an appropriate, unique IP address.

Find useful networking information, under the Help menu, click on User 
Manual. Scroll down to the Basic Network Administration section. 

Set up Your Physical Ethernet Network - You Will Need:
A standard Category 5e cable with 8P8C/RJ-45 connectors on both ends for each 
drive.web  device and your computer.

For systems with more than one drive.web device, an Ethernet switch with ports  for 
all drive.web devices and your computer.

Set up Your Computer - Get savvy
With free drive.web savvy software, easily program and monitor your speedy sp, 
perform data trending and create distributed control systems.

To download the latest version of savvy and to view the savvy user manual, go to 
www.driveweb.com and click on Get savvy.

Java Runtime Environment must be installed to run savvy. There is  a link on the 
Get savvy page to download Java for free. 

If you do not have internet access, install savvy and Java from the Bardac Infodisk. 
Browse to the savvy link, off-line installation. Contact us for the files or Infodisk.

drive.web control technology
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Get started with savvy
We strongly recommend you attend our free on-line training seminars. To register, 
e-mail training@driveweb.com or call.

Before proceeding with your systems designs it is  very important to familiarize 
yourself  with savvy, the configuration software. 

We strongly recommend you read the introductory guides under the Help menu; 
Getting Started with savvy, Getting Started with savvy-SFD, savvy-SFD 
and the PL series drive.   

Use Create Phantom in the Directory menu to practice, explore all drive.web 
products and options and design and configure off-line. Design systems in Phantom 
devices  and Export Data under the Directory menu for later use in live devices. 
Import Data into  phantoms to work off-line. 

Under the Directory menu, click Discover All Local Devices.  If your speedy sp 
is powered and on the same local network as your computer, an icon should appear.  

Discover drive.web devices  anywhere on the internet unless  they are protected by 
firewalls  or other network security devices. Assign a public IP address  or use a VPN. 
Under the Directory menu, click on Discover Device...  

If the icon at right appears  with the red padlock and comms-fail indication, a network 
connection problem exists. Check connections, LEDs  and that the speedy sp IP 
address is within your computer’s subnet mask.  

Warning! Changing a device IP address  WILL disrupt its network connections! If a 
speedy sp is  communicating with other devices or drives  you must be prepared for 
system disruption and to remap connections  in those devices  when changing an IP ad-
dress. In the File menu choose Utility > Remap Export File to remap a dw-system 
file with different IP address(es).

Under the File menu, click Administrate > Set IP Addresses for System.  Locate 
the serial number on the product label of your speedy sp. Enter a unique IP 
address  that is  within your computer’s  subnet mask and click OK.  A speedy sp icon 
should appear with IP address beneath.  

Hover cursor over a device icon, function block, connection or parameter to see 
contextual information in the status  bar at the window top margin and reveal the 
hover button.

Click a hover button or right-click an icon to access its contextual menu.

In the speedy sp contextual menu, choose Change Name to name your speedy sp 
for easy identification. Also, a powerful Find Parameter... function locates  and 
jumps views to a parameter. Simply enter its number, name or partial name.

To Import or Export (load or save) configuration data to or from your speedy sp, use 
its contextual menu.

To Import or Export all configuration and connection data to or from all drive.web 
devices and phantoms in the directory use Directory menu.

Advanced Users: At the bottom of the Setup IP Addresses window, click the arrow 
next to Network Information to set subnet mask and router IP addresses. See the 
savvy user manual. Note! If the Network Information box is  expanded, this 
network information will be set in the device(s) whose IP address(es) are changed.

drive.web control technology
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Get started with savvy continued...

savvy views  are hierarchical with the Directory view at top. Use the navigation 
arrows  in the status bar to view the next higher level or go backward and forward 
through a series of  views. Note that menus change as you navigate. 

savvy function may be limited if you do not have the required capability 
level or a device is locked with a password.

Click the speedy sp icon to view the Engineering Info screen (Standard 
savvy, no SFD). Click the Function Block Engine icon and if you 
have options 02, 04  or 12, the Modbus icon to view. 

In the Function Block Engine view (Standard savvy, no SFD), click the 
FBE menu and select function blocks  in the order that you want them to 
be processed. Processing order is from left to right, then top to bottom.

Click on a function block to view its parameters and functional detail. 

Effortlessly connect between parameters  and to parameters  in other drive.web 
devices over Ethernet. 

Under the File menu, choose New Viewer... and then Open Device Directory. 
Now you can click on a parameter, drag a connection and drop onto a destination 
parameter in the other viewer.   

Use parameter contextual menus for Get Info, Add to Dock, Copy, Connect to… 
start or end connections, Re-name..., and Re-scale...

Click any blue connection to jump views to the other end.

Use connection contextual menus  in drive.web-over-Ethernet and FBE-to-drive 
connections to Change Sample Period… and prioritize connections. 

Click on parameters  to open the setter box. Adjust the value with convenient graphical 
buttons or keyboard entry.

Most drive.web parameters  use 16 bit words  allowing raw decimal integer values 0 
to 65535 or ±32767. These raw values  are formatted, limited and scaled depending 
on the parameter.  Use Get Info or Re-Scale to verify or change.

A blank rectangle connected to or from a parameter indicates  a remote device is  not 
discovered in savvy. 

Very complex function block configurations with numerous  Ethernet connections  may 
produce Timebase Overrun indications  at the System function block. Performance 
WILL be affected. In the System block contextual menu adjust the speedy sp’s 
Timebase Setpoint. Make a connection from the Program Status parameter to 
log these occurrences or provide warning signals.

savvy with Signal Flow Diagram Option - SFD Upgrade
With savvy-SFD, build systems  graphically while creating live 
drawings that are stored in your speedy sp.  

Set borders, drag and drop connections, zoom, pan, cross-
reference and annotate multi-page drawings. 

A separate function block and connection listing shows  program 
execution order from top down. Change execution order by 
dragging function blocks up or down the list. 

drive.web control technology
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Upgrading savvy and speedy sp
Process  a credit card or Vouchers on-line or purchase Coupons for use off-line. Find 
the Shopping Cart under the Commerce menu.

Select Upgrade savvy under the Commerce menu.

Right-click on speedy sp icon and choose Upgrade Device…

To process  Vouchers choose Pay>Online Via Vouchers in the Shopping Cart. 
Enter each Voucher code on a separate line.

Process  Coupons in the Coupon Manager, under the Commerce menu. Enter 
individual codes  in the top box and click the Add button. The Coupon is  recognized. 
Click Apply.

speedy sp Option 04 ModbusTCP/IP Slave/Server
Warning! Use of speedy sp option 04 may cause motors  and machinery to power 
up with high Voltages  or start or operate in an unexpected, dangerous  or lethal way. It 
is  essential that you are completely familiar with the ModbusTCP/IP protocol and all 
of the equipment and the system design you are working with before attempting to 
use this option.

Supports  up to three simultaneous masters. Further connection attempts  are 
refused until a connection is ended. 

Adheres to Modbus Conformance Class 0

Supports Modbus Function Codes 03 and 16

You cannot write or force parameters  that are read-only or have incoming drive.web 
connections.

ModbusTCP Slave Port 502 is  the standard specified in the protocol. You may 
change this to match the master in the unusual case that it is non-standard.

Modbus Indirect function blocks  with sequentially numbered parameters  make best 
use of Modbus  multiple read or write functions. Enter any parameter numbers  to 
read or write with one Modbus operation. 

Directly address  any numbered parameter individually. You are NOT required to use 
Indirect parameters.

drive.web Product Line Overview
dw210 smarty with sixteen analog and digital I/O. Optional dual serial 

ports, dual encoder module, Encoder Control Library with various shaft lock 
and position functions. 100BaseTX Ethernet. SNTP and SMTP support.

dw213 smarty-o with Optidrive Plus AC Drive serial link.

speedy485 Add drive.web power and ModbusTCP via ModbusRTU. 

savvy-sfd Signal Flow Diagram Option see page 5.

speedy sp & all drive.web products are designed & assembled in the U.S.A.

Get expert drive.web help. Call or email techsupport@driveweb.com

drive.web Training Courses
Free drive.web online interactive training seminars take about one hour. 

Specialized online and factory training sessions are also available.  

To register email training@driveweb.com or call.

drive.web control technology
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drive.web 40 Log Canoe Circle, Stevensville, MD 21666 USA. 
Ph. 410-604-3400, Fax 410-604-3500, www.driveweb.com
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